OpenCart 2.3.0.2 Mail Alerts Error / İlave Uyarı E-Posta Gönderimi

OpenCart 2.3.0.2 sürümünü kullanmam itibariyle karşılaşmış olduğum bir hatadır.
Uyarı Mesajları, Mail Alerts başlığı altında bulunmakta ve seçilen işlemler ile ilgili e-postaların belirlediğiniz mail adreslerine de gönderilmesini sağlıyor.
Hatalardan biri; Girilen mail adreslerinin ayarlarda görünmemesi, diğeri ise buraya girilen mail adreslerine mail gönderilmemesi.
Girilen mail adresleri veritabanına kaydediliyor fakat görünmüyor.

Opencart 2.3.0.2 mail alerts


1) Dosya: catalog/model/checkout/order.php
Bul:
$emails = explode(',', $this->config->get('config_alert_email'));

İle değiştir:
$emails = explode(',', $this->config->get('config_mail_alert_email'));


2) Dosya: admin/controller/setting/setting.php
Bul:
if (isset($this->request->post['config_alert_email'])) {

Üstüne ekle:
if (isset($this->request->post['config_mail_alert_email'])) {
	$data['config_mail_alert_email'] = $this->request->post['config_mail_alert_email'];
} else {
	$data['config_mail_alert_email'] = $this->config->get('config_mail_alert_email');
}


3) Dosya: admin/view/template/setting/setting.tpl
Bul:
$config_alert_email;

İle değiştir:
$config_mail_alert_email;
Devamı
+5

Laravel 5.3 Zizaco Entrust - Class name must be a valid object or a string

Zizaco Entrust
$role = Role::findOrFail( $id );
$role->delete();

Kodu kullanıldığında alınan hata:
Class name must be a valid object or a string

Çözmek için
config/auth.php yi açın
Aşağıdaki kodu ekleyin
// For zizaco/entrust
'model' => App\User::class,

Son hali bu şekilde olacak:
    // For zizaco/entrust
    'model' => App\User::class,

    'providers' => [
        'users' => [
            'driver' => 'eloquent',
            'model' => App\User::class,
            'table' => 'users',
        ],

        // 'users' => [
        //     'driver' => 'database',
        //     'table' => 'users',
        // ],
    ],

Sonrasında aşağıdaki komutu çalıştırın:
php artisan config:cache
Devamı
+3

Invalid revision: 12.0.2753695 beta 1 - Android Studio

Invalid revision: 12.0.2753695 beta 1 hatasını çözmek için Beta sürüm olan NDK'i kaldırıp son Stabil sürüme dönebilirsiniz.
Veya
Aşağıdaki dosyayı açıp
$SDK/ndk-bundle/source.properties

İçeriği
Pkg.Desc = Android NDK
Pkg.Revision = 12.0.2753695 beta 1

Bununla değiştirin
Pkg.Desc = Android NDK
Pkg.Revision = 12.0.2753695-beta1

$SDK = Android SDK'in kurulu olduğu dizin
Devamı
+8